# CVE-2026-45128: MyBB: ACP Users View Manager default CSRF


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-m6hr-25cj-p58q

## What is CVE-2026-45128?

CVE-2026-45128 is a low-severity vulnerability in mybb, published on 18 Aug 2026. 

### Official description

MyBB is free and open source forum software. Prior to 1.8.40, the ACP Users View Manager module does not validate requests correctly, allowing same-site attackers to change a victim administrator's default user list view by embedding a specially crafted URL. The Set as Default control named set_default in Admin CP, Users & Groups, Users, View Manager changes the administrator's default view on GET requests without request forgery protection. The uniquely identifying implementation details include Users & Groups → Users → View Manager, and admin/inc/functions_view_manager.php. This issue is fixed in version 1.8.40.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-45128?


## How do I fix CVE-2026-45128?

No fix has been published for CVE-2026-45128 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45128 being exploited?

There is no known exploitation of CVE-2026-45128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45128 and fix it if it is affected.

What it is: CVE-2026-45128 is a low-severity vulnerability in mybb, published on 18 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-45128 in the wild and no public exploit code.

Affected product: mybb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45128/ (Markdown: https://insights.sbomify.com/CVE-2026-45128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45128
- OSV: https://osv.dev/vulnerability/CVE-2026-45128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45128/
Summaries are generated and may contain mistakes; the official description above is the record.
