CVE-2026-45133 Symfony: [Yaml] Harden the parser when handling untrusted input
Attackers can crash the application by submitting deeply nested YAML documents, causing stack exhaustion in the Symfony parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45133?
CVE-2026-45133 is a high-severity denial of service vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Which versions are affected by CVE-2026-45133?
16 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
10 more packages
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45133?
Upgrade symfony/symfony to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-45133 being exploited?
There is no known exploitation of CVE-2026-45133 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1784250517, CLSA-2026-1787232806, DEBIAN-CVE-2026-45133, GHSA-c2p3-7m5p-cv8x, MINI-4q29-hjj5-jhgw, MINI-6pq5-p3p9-p257 and 2 more.