# CVE-2026-45133: Symfony: [Yaml] Harden the parser when handling untrusted input

> Attackers can crash the application by submitting deeply nested YAML documents, causing stack exhaustion in the Symfony parser.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLSA-2026-1784250517, CLSA-2026-1787232806, DEBIAN-CVE-2026-45133, GHSA-c2p3-7m5p-cv8x, MINI-4q29-hjj5-jhgw, MINI-6pq5-p3p9-p257, MINI-c43f-9xcm-j56p, UBUNTU-CVE-2026-45133

## What is CVE-2026-45133?

CVE-2026-45133 is a high-severity denial of service vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs), CWE-674 (Uncontrolled Recursion), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-45133?

16 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | All versions | 5.4.52 |
| `symfony/symfony` | Packagist | All versions | 5.4.52 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/yaml` | Packagist | All versions | 5.4.52 |
| `symfony/yaml` | Packagist | All versions | 5.4.52 |
| `symfony/yaml` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/yaml` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/yaml` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/yaml` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/yaml` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/yaml` | Packagist | From 8.0.0 | 8.0.12 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2026-45133?

Upgrade symfony/symfony to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.

## Is CVE-2026-45133 being exploited?

There is no known exploitation of CVE-2026-45133 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45133 and fix it if it is affected.

What it is: CVE-2026-45133 is a high-severity denial of service vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45133 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.52
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.52
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/yaml (Packagist): affected all versions; fixed in 5.4.52
- symfony/yaml (Packagist): affected all versions; fixed in 5.4.52
- symfony/yaml (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/yaml (Packagist): affected from 6.0.0; fixed in 6.4.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45133/ (Markdown: https://insights.sbomify.com/CVE-2026-45133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45133
- OSV: https://osv.dev/vulnerability/CVE-2026-45133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45133/
Summaries are generated and may contain mistakes; the official description above is the record.
