CVE-2026-45134 LangSmith Client SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
Attackers can execute arbitrary code by providing malicious serialized manifests in public LangSmith prompts, affecting SDK users pulling external content.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-45134?
CVE-2026-45134 is a high-severity unsafe deserialization vulnerability in langchain-ai langsmith-sdk, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. Prior to LangSmith SDK Python 0.8.0 and JS/TS 0.6.0, the LangSmith SDK's prompt pull methods (pull_prompt / pull_prompt_commit in Python, pullPrompt / pullPromptCommit in JS/TS) fetch and deserialize prompt manifests from the LangSmith Hub. These manifests may contain serialized LangChain objects and model configuration that affect runtime behavior. When pulling a public prompt by owner/name identifier, the manifest content is controlled by an external party, but prior versions of the SDK did not distinguish this from pulling a prompt within the caller's own organization. This vulnerability is fixed in LangSmith SDK Python 0.8.0 and JS/TS 0.6.0.
Weakness: CWE-502
Which versions are affected by CVE-2026-45134?
11 open source packages ship an affected version, including langsmith, langchain and langchain-classic.
| Package | Affected | Fixed in |
|---|---|---|
langsmith PyPI | All versions | 0.8.0 |
langsmith PyPI | All versions | 0.8.0 |
langsmith PyPI | All versions | 0.8.0 |
langsmith npm | All versions | 0.6.0 |
langsmith npm | All versions | 0.6.0 |
langchain PyPI | All versions | 0.3.30 |
5 more packages
langchain PyPI | All versions | 0.3.30 |
langchain PyPI | All versions | 0.3.30 |
langchain-classic PyPI | All versions | 1.0.7 |
langchain-classic PyPI | All versions | 1.0.7 |
langchain-classic PyPI | All versions | 1.0.7 |
How do I fix CVE-2026-45134?
Upgrade langsmith to a fixed version for your release line: 0.8.0 or 0.6.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-45134 being exploited?
There is no known exploitation of CVE-2026-45134 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-DX34363, ECHO-442c-bb23-6599, GHSA-3644-q5cj-c5c7, MINI-2xp4-cr7x-rvv9, MINI-5rp5-8rvg-882p, MINI-65m3-p8fc-33r4 and 15 more.