# CVE-2026-45135: Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files

> Attackers can execute arbitrary code by exploiting unsafe Unicode handling in Caddy's FastCGI module to bypass script extension checks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-CJ43596, DEBIAN-CVE-2026-45135, GHSA-m675-2p33-xv9g, GO-2026-5492, MINI-8qh5-r8h3-45gp, UBUNTU-CVE-2026-45135

## What is CVE-2026-45135?

CVE-2026-45135 is a high-severity code injection vulnerability in caddyserver caddy, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. From 2.7.0 until 2.11.3, the FastCGI transport's splitPos() in modules/caddyhttp/reverseproxy/fastcgi/fastcgi.go misuses golang.org/x/text/search with search.IgnoreCase when the request path contains a non-ASCII byte. Two distinct flaws in that fallback let an attacker mislead Caddy's FastCGI splitting into treating a non-.php (or other configured split_path extension) file as a script. In any deployment where the attacker can place content into a file served via FastCGI (uploads, file storage, etc.), this can be escalated to remote code execution by crafting a URL whose path triggers either flaw. This vulnerability is fixed in 2.11.3.

Weakness: CWE-20 (Improper Input Validation), CWE-178 (Improper Handling of Case Sensitivity), CWE-176 (Improper Handling of Unicode Encoding)

## Which versions are affected by CVE-2026-45135?

3 open source packages ship an affected version, including github.com/caddyserver/caddy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2` | Go | From 2.7.0 | 2.11.3 |
| `github.com/caddyserver/caddy/v2` | Go | From 2.7.0 | 2.11.3 |
| `github.com/caddyserver/caddy/v2` | Go | From 2.7.0 | 2.11.3 |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-45135?

Upgrade github.com/caddyserver/caddy/v2 to 2.11.3 or later.

## Is CVE-2026-45135 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45135 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)
- [CVE-2026-30851](https://insights.sbomify.com/CVE-2026-30851/): Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45135 and fix it if it is affected.

What it is: CVE-2026-45135 is a high-severity code injection vulnerability in caddyserver caddy, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45135 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2 (Go): affected from 2.7.0; fixed in 2.11.3
- github.com/caddyserver/caddy/v2 (Go): affected from 2.7.0; fixed in 2.11.3
- github.com/caddyserver/caddy/v2 (Go): affected from 2.7.0; fixed in 2.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45135/ (Markdown: https://insights.sbomify.com/CVE-2026-45135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45135
- OSV: https://osv.dev/vulnerability/CVE-2026-45135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45135/
Summaries are generated and may contain mistakes; the official description above is the record.
