# CVE-2026-45138: CI4MS: Stored XSS in Blog Content via Broken `html_purify` Validation Rule

> Stored XSS in CI4MS blog content allows attackers to execute scripts in visitors' browsers, including admins, due to broken sanitization.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-2m69-jmvh-6chr

## What is CVE-2026-45138?

CVE-2026-45138 is a medium-severity cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 19 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CI4MS is a CodeIgniter 4-based content management system skeleton. Prior to version 0.31.9.0, the custom `html_purify` validation rule used to sanitize blog post bodies relies on by-reference mutation (`?string &$str`), but CodeIgniter 4's validator passes a local copy of the value, so the sanitized text is silently discarded. The Blog controller writes `$lanData['content']` directly into `blog_langs.content`, and the public template echoes it without escaping — yielding stored XSS executable in any visitor's browser, including the superadmin when previewing or editing posts. Version 0.31.9.0 patches the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45138?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.9.0 |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.9.0 |

## How do I fix CVE-2026-45138?

Upgrade ci4-cms-erp/ci4ms to 0.31.9.0 or later.

## Is CVE-2026-45138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45138 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45138 and fix it if it is affected.

What it is: CVE-2026-45138 is a medium-severity cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 19 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45138 exists.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.9.0
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45138/ (Markdown: https://insights.sbomify.com/CVE-2026-45138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45138
- OSV: https://osv.dev/vulnerability/CVE-2026-45138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45138/
Summaries are generated and may contain mistakes; the official description above is the record.
