# CVE-2026-45140: Chamilo LMS CStudio upload flow allows unauthenticated remote code execution

> Unauthenticated attackers can execute arbitrary code on Chamilo LMS servers via the CStudio upload flow.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-g4c3-4g96-6g4m

## What is CVE-2026-45140?

CVE-2026-45140 is a critical vulnerability in chamilo-lms, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Chamilo LMS is an open-source learning management system. Prior to 2.0.1, Chamilo LMS allows an unauthenticated remote attacker to execute arbitrary code on the server. The authoritative advisory does not identify the affected endpoint, component, input, or exploitation mechanism. This issue is fixed in version 2.0.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-219 (Storage of File with Sensitive Data Under Web Root)

## Which versions are affected by CVE-2026-45140?

2 open source packages ship an affected version, including chamilo/chamilo-lms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chamilo/chamilo-lms` | Packagist | All versions | 2.0.1 |
| `chamilo/chamilo-lms` | Packagist | All versions | 2.0.1 |

## How do I fix CVE-2026-45140?

Upgrade chamilo/chamilo-lms to 2.0.1 or later.

## Is CVE-2026-45140 being exploited?

There is no known exploitation of CVE-2026-45140 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-45140 - chamilo - Critical 9.8 - Unauthenticated POST /plugin/CStudio/editor/import-project... - Remote Code Execution (github_poc): https://github.com/abraxas/CVE-2026-45140

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45140 and fix it if it is affected.

What it is: CVE-2026-45140 is a critical vulnerability in chamilo-lms, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45140 in the wild and no public exploit code.

Affected packages and fixed versions:
- chamilo/chamilo-lms (Packagist): affected all versions; fixed in 2.0.1
- chamilo/chamilo-lms (Packagist): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45140/ (Markdown: https://insights.sbomify.com/CVE-2026-45140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45140
- OSV: https://osv.dev/vulnerability/CVE-2026-45140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45140/
Summaries are generated and may contain mistakes; the official description above is the record.
