# CVE-2026-45143: Chamilo LMS: Student-to-admin stored XSS in private messages via v-html

> Authenticated students can inject malicious scripts into private messages, leading to administrator account takeover when the admin views the message.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-x88v-rg6r-vqq6

## What is CVE-2026-45143?

CVE-2026-45143 is a critical cross-site scripting vulnerability in chamilo-lms, published on 17 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Chamilo LMS is an open-source learning management system. From 2.0.0 through at least 2.1.0, Chamilo LMS stores private Message.content without server-side sanitization and renders it as HTML in assets/vue/views/message/MessageShow.vue and public/main/template/default/message/view_message.html.twig. An authenticated low-privilege user, including a student, can directly address crafted message content to an administrator because the message creation flow permits a sender to select another user as the recipient. The content executes in the recipient's browser when the recipient opens the routine inbox or message view, without requiring a link click, and can expose session credentials or permit actions as the administrator. This vulnerability is fixed in 2.0.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45143?


## How do I fix CVE-2026-45143?

No fix has been published for CVE-2026-45143 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45143 being exploited?

There is no known exploitation of CVE-2026-45143 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45143 and fix it if it is affected.

What it is: CVE-2026-45143 is a critical cross-site scripting vulnerability in chamilo-lms, published on 17 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45143 in the wild and no public exploit code.

Affected product: chamilo-lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45143/ (Markdown: https://insights.sbomify.com/CVE-2026-45143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45143
- OSV: https://osv.dev/vulnerability/CVE-2026-45143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45143/
Summaries are generated and may contain mistakes; the official description above is the record.
