# CVE-2026-45157: Nextcloud: Valid share tokens allow to access tempory upload files of share owner

> Attackers with valid share tokens can access temporary upload files of the share owner, exposing sensitive data during ongoing uploads.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** BIT-nextcloud-2026-45157, GHSA-45pj-p7x7-4mhc

## What is CVE-2026-45157?

CVE-2026-45157 is a medium-severity missing authorization vulnerability in nextcloud security-advisories, published on 1 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, when a malicious user has access to a file share of a user, they could use this share token to also access the chunking upload directly and see temporary part files during on going uploads. It is recommended that the Nextcloud Server is upgraded to 32.0.9 or 33.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 26.0.13.26, 27.1.11.25, 28.0.14.17, 29.0.16.16, 30.0.17.9, 31.0.14.5, 32.0.9 or 33.0.3

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-45157?

1 open source package ship an affected version, including nextcloud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud` | Bitnami | From 32.0.0 | 32.0.9, 33.0.3 |

## How do I fix CVE-2026-45157?

Upgrade nextcloud to a fixed version for your release line: 32.0.9 or 33.0.3.

## Is CVE-2026-45157 being exploited?

There is no known exploitation of CVE-2026-45157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45157 and fix it if it is affected.

What it is: CVE-2026-45157 is a medium-severity missing authorization vulnerability in nextcloud security-advisories, published on 1 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45157 in the wild and no public exploit code.

Affected packages and fixed versions:
- nextcloud (Bitnami): affected from 32.0.0; fixed in 32.0.9, 33.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45157/ (Markdown: https://insights.sbomify.com/CVE-2026-45157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45157
- OSV: https://osv.dev/vulnerability/CVE-2026-45157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45157/
Summaries are generated and may contain mistakes; the official description above is the record.
