# CVE-2026-45162: Pimcore: Unsafe PHP Deserialization in Multiple Locations Without allowed_classes Restriction

> Attackers can achieve remote code execution in Pimcore by exploiting unsafe PHP deserialization in multiple components without class restrictions.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-36fc-7wjg-mfvj

## What is CVE-2026-45162?

CVE-2026-45162 is a high-severity unsafe deserialization vulnerability in pimcore, published on 17 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.17 (LTS) and 12.3.7, multiple Pimcore locations call PHP's unserialize() on data from database columns and filesystem files without the allowed_classes restriction, including lib/Tool/Authentication.php, models/Site/Dao.php, models/DataObject/ClassDefinition/CustomLayout/Dao.php, models/Tool/TmpStore/Dao.php, models/Asset/WebDAV/Service.php, and admin-ui-classic-bundle/src/Helper/Dashboard.php, enabling object injection and remote code execution if an attacker can control the serialized data source. This issue is fixed in versions 11.5.17 (LTS) and 12.3.7.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-45162?

6 open source packages ship an affected version, including pimcore/pimcore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 11.5.17 |
| `pimcore/pimcore` | Packagist | All versions | 11.5.17 |
| `pimcore/pimcore` | Packagist | From 12.0.0-RC1 | 12.3.7 |
| `pimcore/pimcore` | Packagist | From 12.0.0-RC1 | 12.3.7 |
| `pimcore/pimcore` | Packagist | From 2026.1.0 | 2026.1.3 |
| `pimcore/pimcore` | Packagist | From 2026.1.0 | 2026.1.3 |

## How do I fix CVE-2026-45162?

Upgrade pimcore/pimcore to a fixed version for your release line: 11.5.17, 12.3.7 or 2026.1.3.

## Is CVE-2026-45162 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45162 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45162 and fix it if it is affected.

What it is: CVE-2026-45162 is a high-severity unsafe deserialization vulnerability in pimcore, published on 17 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45162 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 11.5.17
- pimcore/pimcore (Packagist): affected all versions; fixed in 11.5.17
- pimcore/pimcore (Packagist): affected from 12.0.0-RC1; fixed in 12.3.7
- pimcore/pimcore (Packagist): affected from 12.0.0-RC1; fixed in 12.3.7
- pimcore/pimcore (Packagist): affected from 2026.1.0; fixed in 2026.1.3
- pimcore/pimcore (Packagist): affected from 2026.1.0; fixed in 2026.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45162/ (Markdown: https://insights.sbomify.com/CVE-2026-45162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45162
- OSV: https://osv.dev/vulnerability/CVE-2026-45162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45162/
Summaries are generated and may contain mistakes; the official description above is the record.
