# CVE-2026-45222: Summarize Insecure Daemon Configuration File Permissions

> Local attackers can read world-readable daemon configuration files to steal bearer tokens and API credentials, leading to unauthorized access.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-qp7v-gjgg-4mj6

## What is CVE-2026-45222?

CVE-2026-45222 is a medium-severity vulnerability in steipete summarize, published on 11 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Summarize versions through 0.14.1, fixed in commit 0cfb0fb, creates the daemon configuration directory and file with default filesystem permissions that may be world-readable on Unix-like systems, allowing local attackers to read bearer tokens and API credentials stored in ~/.summarize/daemon.json. A local attacker can exploit these permissive permissions to read the daemon bearer token and persisted provider credentials, enabling unauthorized access to the daemon or recovery of sensitive API keys.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-45222?

2 open source packages ship an affected version, including @steipete/summarize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@steipete/summarize` | npm | All versions | 0.15.0 |
| `@steipete/summarize` | npm | All versions | 0.15.0 |

## How do I fix CVE-2026-45222?

Upgrade @steipete/summarize to 0.15.0 or later.

## Is CVE-2026-45222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45222 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45222 and fix it if it is affected.

What it is: CVE-2026-45222 is a medium-severity vulnerability in steipete summarize, published on 11 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45222 exists.

Affected packages and fixed versions:
- @steipete/summarize (npm): affected all versions; fixed in 0.15.0
- @steipete/summarize (npm): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45222/ (Markdown: https://insights.sbomify.com/CVE-2026-45222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45222
- OSV: https://osv.dev/vulnerability/CVE-2026-45222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45222/
Summaries are generated and may contain mistakes; the official description above is the record.
