{"answers":{"affected":"2 open source packages ship an affected version, including echarts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-45249 in the wild and no public exploit code.","fix":"Upgrade echarts to 6.1.0 or later.","what":"CVE-2026-45249 is a medium-severity cross-site scripting vulnerability in Apache ECharts, published on 25 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45249 and fix it if it is affected.\n\nWhat it is: CVE-2026-45249 is a medium-severity cross-site scripting vulnerability in Apache ECharts, published on 25 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-45249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- echarts (npm): affected all versions; fixed in 6.1.0\n- echarts (npm): affected all versions; fixed in 6.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45249/ (Markdown: https://insights.sbomify.com/CVE-2026-45249/index.md)","id":"CVE-2026-45249","markdown":"https://insights.sbomify.com/CVE-2026-45249/index.md","name":"CVE-2026-45249","record":{"aliases":["CLEANSTART-2026-FL24819","GHSA-fgmj-fm8m-jvvx","MINI-2659-pcpv-2jqm","MINI-5cq4-8vh6-273w","MINI-pqf3-q2p9-pmqg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript charting library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in Apache ECharts Lines series tooltips when specific rendering conditions are met.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"echarts","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting (XSS) vulnerability exists in Apache ECharts in the Lines series tooltip rendering logic.\n\nThis issue affects Apache ECharts: from before 6.1.0.\n\nIn versions prior to 6.1.0, if both Lines series and tooltip are used, and no user-specified tooltip.formatter is provided, and series.data[i].name is specified, raw HTML string series.data[i].name can be rendered through innerHTML sink into tooltip content. Although tooltip is allowed to accept user-provided raw HTML via a custom tooltip.formatter, the built-in tooltip formatters conventionally perform HTML escaping automatically. This case breaks that convention and may unexpectedly lead to script execution when tooltips are displayed.\n\nUsers are recommended to upgrade to version 6.1.0 if using the Lines series in this way, which fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ECharts: XSS in Lines series tooltip rendering","id":"CVE-2026-45249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Stack buffer overflow via setcred(2)","id":"CVE-2026-45250"},"packages":[{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"echarts","purl":null,"source":"GHSA-fgmj-fm8m-jvvx"},{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"echarts","purl":"pkg:npm/echarts","source":"GHSA-fgmj-fm8m-jvvx"}],"prev":{"headline":"Hedera Guardian Authentication Bypass Information Disclosure","id":"CVE-2026-45248"},"products":["Apache ECharts"],"published":"2026-05-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-26","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary scripts via XSS in Apache ECharts Lines series tooltips when specific rendering conditions are met.","url":"https://insights.sbomify.com/CVE-2026-45249/"}