# CVE-2026-45261: GitButler: Link injection via forge integration enables arbitrary script execution

> Attackers can execute arbitrary scripts in GitButler by injecting malicious links into pull requests, affecting users with forge integration enabled.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 May 2026
- **Updated:** 30 May 2026
- **Also known as:** GHSA-xpmj-536r-9fc6

## What is CVE-2026-45261?

CVE-2026-45261 is a critical code injection vulnerability in gitbutlerapp gitbutler, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

GitButler is a modern Git-based version control interface for AI-powered workflows. Prior to 0.19.7, a emote code execution vulnerability exists in the Tauri-based GitButler desktop application. An attacker can inject a malicious link in a pull request body, which if clicked by the user allows for arbitrary script execution in the Tauri webview. Users that have not enabled forge integration are not at risk. This vulnerability is fixed in 0.19.7.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-45261?


## How do I fix CVE-2026-45261?

No fix has been published for CVE-2026-45261 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45261 being exploited?

There is no known exploitation of CVE-2026-45261 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45261 and fix it if it is affected.

What it is: CVE-2026-45261 is a critical code injection vulnerability in gitbutlerapp gitbutler, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45261 in the wild and no public exploit code.

Affected product: gitbutlerapp gitbutler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45261/ (Markdown: https://insights.sbomify.com/CVE-2026-45261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45261
- OSV: https://osv.dev/vulnerability/CVE-2026-45261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45261/
Summaries are generated and may contain mistakes; the official description above is the record.
