CVE-2026-45279 Nextcloud: Limited path traversal via template API if using `{lang}` in config

Medium 4.4 Published Updated

Non-admin users can copy arbitrary files into their directory via path traversal if the template config uses {lang}, requiring an upgrade.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45279?

CVE-2026-45279 is a medium-severity path traversal vulnerability in Nextcloud Nextcloud Server, published on 1 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 31.0.0 to before 31.0.14, and 32.0.0 to before 32.0.4, if {lang} is used in the template directory config value, non-admin users can in some cases copy arbitrary files (depending on unix permissions) into their own Nextcloud directory via a path traversal. It is recommended that the Nextcloud Server is upgraded to 32.0.4, 31.0.14. It is recommended that the Nextcloud Enterprise Server is upgraded to 32.0.4, 31.0.14, 30.0.17.7, 29.0.17.12, 28.0.14.15

Weakness: CWE-22

Which versions are affected by CVE-2026-45279?

It affects 1 product.

Products include Nextcloud Nextcloud Server.

How do I fix CVE-2026-45279?

No fix has been published for CVE-2026-45279 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-45279 being exploited?

There is no known exploitation of CVE-2026-45279 in the wild and no public exploit code.

All Nextcloud Nextcloud Server vulnerabilities

Sources

Also known as GHSA-j33j-qph5-4wch.

Is CVE-2026-45279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free