CVE-2026-45291 Cloudburst Network erroneously handles invalid connections

High 7.5 Published Updated

An attacker can close the parent netty channel in Cloudburst Network, causing a denial of service for dependent software.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45291?

CVE-2026-45291 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260418.124334-32` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a bug in Network to close the parent netty channel, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260418.124334-32`. There are no known workarounds beyond updating the library.

Weakness: CWE-20

Which versions are affected by CVE-2026-45291?

How do I fix CVE-2026-45291?

No fix has been published for CVE-2026-45291 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-45291 being exploited?

There is no known exploitation of CVE-2026-45291 in the wild and no public exploit code.

Sources

Is CVE-2026-45291 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free