# CVE-2026-45291: Cloudburst Network erroneously handles invalid connections

> An attacker can close the parent netty channel in Cloudburst Network, causing a denial of service for dependent software.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Jun 2026
- **Updated:** 8 Jun 2026

## What is CVE-2026-45291?

CVE-2026-45291 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260418.124334-32` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a bug in Network to close the parent netty channel, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260418.124334-32`. There are no known workarounds beyond updating the library.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-45291?


## How do I fix CVE-2026-45291?

No fix has been published for CVE-2026-45291 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45291 being exploited?

There is no known exploitation of CVE-2026-45291 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45291 and fix it if it is affected.

What it is: CVE-2026-45291 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45291 in the wild and no public exploit code.

Affected product: CloudburstMC Network. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45291/ (Markdown: https://insights.sbomify.com/CVE-2026-45291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45291
- OSV: https://osv.dev/vulnerability/CVE-2026-45291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45291/
Summaries are generated and may contain mistakes; the official description above is the record.
