CVE-2026-45293 WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability

High 8.6 Published Updated

Attackers can execute arbitrary code on scanning hosts by providing malicious PHP arguments to WordPressCS sniffs during linting of untrusted code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-45293?

CVE-2026-45293 is a high-severity code injection vulnerability in WordPress-Coding-Standards, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.

Weakness: CWE-95

Which versions are affected by CVE-2026-45293?

2 open source packages ship an affected version, including wp-coding-standards/wpcs.

PackageAffectedFixed in
wp-coding-standards/wpcs PackagistFrom 0.14.13.4.1
wp-coding-standards/wpcs PackagistFrom 0.14.13.4.1

How do I fix CVE-2026-45293?

Upgrade wp-coding-standards/wpcs to 3.4.1 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-45293 being exploited?

There is no known exploitation of CVE-2026-45293 in the wild and no public exploit code.

Sources

Also known as GHSA-3pwp-g2mj-5p3v.

Is CVE-2026-45293 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free