{"answers":{"affected":"2 open source packages ship an affected version, including wp-coding-standards/wpcs.","exploited":"There is no known exploitation of CVE-2026-45293 in the wild and no public exploit code.","fix":"Upgrade wp-coding-standards/wpcs to 3.4.1 or later.","what":"CVE-2026-45293 is a high-severity code injection vulnerability in WordPress-Coding-Standards, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45293 and fix it if it is affected.\n\nWhat it is: CVE-2026-45293 is a high-severity code injection vulnerability in WordPress-Coding-Standards, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-45293 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wp-coding-standards/wpcs (Packagist): affected from 0.14.1; fixed in 3.4.1\n- wp-coding-standards/wpcs (Packagist): affected from 0.14.1; fixed in 3.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45293/ (Markdown: https://insights.sbomify.com/CVE-2026-45293/index.md)","id":"CVE-2026-45293","markdown":"https://insights.sbomify.com/CVE-2026-45293/index.md","name":"CVE-2026-45293","record":{"aliases":["GHSA-3pwp-g2mj-5p3v"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WordPress coding standards","requires_auth":"none","summary":"Attackers can execute arbitrary code on scanning hosts by providing malicious PHP arguments to WordPressCS sniffs during linting of untrusted code.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability","id":"CVE-2026-45293","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"FreeScout: User Account Enumeration via Password Reset Response Differentiation","id":"CVE-2026-45294"},"packages":[{"ecosystem":"Packagist","fixed":["3.4.1"],"introduced":["0.14.1"],"last_affected":[],"package":"wp-coding-standards/wpcs","purl":null,"source":"GHSA-3pwp-g2mj-5p3v"},{"ecosystem":"Packagist","fixed":["3.4.1"],"introduced":["0.14.1"],"last_affected":[],"package":"wp-coding-standards/wpcs","purl":"pkg:composer/wp-coding-standards/wpcs","source":"GHSA-3pwp-g2mj-5p3v"}],"prev":{"headline":"opentelemetry-java: Unbounded Memory Allocation in W3C Baggage Propagation","id":"CVE-2026-45292"},"products":["WordPress-Coding-Standards"],"published":"2026-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["WordPress"]},"summary":"Attackers can execute arbitrary code on scanning hosts by providing malicious PHP arguments to WordPressCS sniffs during linting of untrusted code.","url":"https://insights.sbomify.com/CVE-2026-45293/"}