# CVE-2026-45293: WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability

> Attackers can execute arbitrary code on scanning hosts by providing malicious PHP arguments to WordPressCS sniffs during linting of untrusted code.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-3pwp-g2mj-5p3v

## What is CVE-2026-45293?

CVE-2026-45293 is a high-severity code injection vulnerability in WordPress-Coding-Standards, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-45293?

2 open source packages ship an affected version, including wp-coding-standards/wpcs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-coding-standards/wpcs` | Packagist | From 0.14.1 | 3.4.1 |
| `wp-coding-standards/wpcs` | Packagist | From 0.14.1 | 3.4.1 |

## How do I fix CVE-2026-45293?

Upgrade wp-coding-standards/wpcs to 3.4.1 or later.

## Is CVE-2026-45293 being exploited?

There is no known exploitation of CVE-2026-45293 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45293 and fix it if it is affected.

What it is: CVE-2026-45293 is a high-severity code injection vulnerability in WordPress-Coding-Standards, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45293 in the wild and no public exploit code.

Affected packages and fixed versions:
- wp-coding-standards/wpcs (Packagist): affected from 0.14.1; fixed in 3.4.1
- wp-coding-standards/wpcs (Packagist): affected from 0.14.1; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45293/ (Markdown: https://insights.sbomify.com/CVE-2026-45293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45293
- OSV: https://osv.dev/vulnerability/CVE-2026-45293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45293/
Summaries are generated and may contain mistakes; the official description above is the record.
