# CVE-2026-45300: async-http-client: Cookie header not stripped on cross-origin redirect

> The AsyncHttpClient library leaks session cookies to cross-origin redirect targets, allowing attackers to steal sensitive authentication data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** CLEANSTART-2026-LW03100, CLEANSTART-2026-WW03960, ECHO-3fd2-6923-7358, GHSA-fmxf-pm6p-7xgm, MINI-2xp7-hq6r-pf29, MINI-m668-g893-3h3m, ROOT-APP-MAVEN-CVE-2026-45300, UBUNTU-CVE-2026-45300

## What is CVE-2026-45300?

CVE-2026-45300 is a high-severity vulnerability in AsyncHttpClient async-http-client, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The AsyncHttpClient (AHC) library allows Java applications to easily execute HTTP requests and asynchronously process HTTP responses. Versions on the 2.x branch prior to 2.15.0 and the 3.x branch prior to 3.0.10 leak `Cookie` headers to cross-origin redirect targets. When following a redirect to a different origin, the `propagatedHeaders()` method in `Redirect30xInterceptor.java` strips `Authorization` and `Proxy-Authorization` headers but does not strip the `Cookie` header, causing session cookies and other sensitive cookie values to be sent to attacker-controlled servers. Versions 2.15.0 and 3.0.10 patch the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-45300?

4 open source packages ship an affected version, including org.asynchttpclient:async-http-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.asynchttpclient:async-http-client` | Maven | From 2.0.0 | 2.15.0 |
| `org.asynchttpclient:async-http-client` | Maven | From 2.0.0 | 2.15.0 |
| `org.asynchttpclient:async-http-client` | Maven | From 3.0.0.Beta1 | 3.0.10 |
| `org.asynchttpclient:async-http-client` | Maven | From 3.0.0.Beta1 | 3.0.10 |

Products: Asynchttpclient Project Async-Http-Client.

## How do I fix CVE-2026-45300?

Upgrade org.asynchttpclient:async-http-client to a fixed version for your release line: 2.15.0 or 3.0.10.

## Is CVE-2026-45300 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45300 exists.

## Other vulnerabilities in AsyncHttpClient async-http-client

- [CVE-2023-0040](https://insights.sbomify.com/CVE-2023-0040/): Async HTTP Client has CRLF Injection vulnerability in HTTP request headers (high 7.5)
- [CVE-2017-14063](https://insights.sbomify.com/CVE-2017-14063/): Improper Input Validation in async-http-client (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45300 and fix it if it is affected.

What it is: CVE-2026-45300 is a high-severity vulnerability in AsyncHttpClient async-http-client, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45300 exists.

Affected packages and fixed versions:
- org.asynchttpclient:async-http-client (Maven): affected from 2.0.0; fixed in 2.15.0
- org.asynchttpclient:async-http-client (Maven): affected from 2.0.0; fixed in 2.15.0
- org.asynchttpclient:async-http-client (Maven): affected from 3.0.0.Beta1; fixed in 3.0.10
- org.asynchttpclient:async-http-client (Maven): affected from 3.0.0.Beta1; fixed in 3.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45300/ (Markdown: https://insights.sbomify.com/CVE-2026-45300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45300
- OSV: https://osv.dev/vulnerability/CVE-2026-45300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45300/
Summaries are generated and may contain mistakes; the official description above is the record.
