# CVE-2026-45303: Open WebUI: Stored XSS via the HTML renedering view

> Attackers can inject scripts via HTML rendering view to execute code and access parent data due to weak iframe sandboxing.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-4vrc-m9ch-6m3r, PYSEC-2026-2704

## What is CVE-2026-45303?

CVE-2026-45303 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.6.5, through the HTML rendering view, scripts can be injected and executed. The frontend provides a function to visualize the HTML content of a current chat. The content is embedded in an iFrame with the allow-scripts allow-forms allow-same-origin sandbox directive. This means that the content is placed in a sandbox but with permission to execute scripts and access the parent’s data (e.g., local storage). As a result, only a few functions are restricted (e.g., displaying an alert box), but in effect, the sandbox attribute is largely nullified. This vulnerability is fixed in 0.6.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45303?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.5 |
| `open-webui` | PyPI | All versions | 0.6.5 |
| `open-webui` | PyPI | All versions | 0.6.5 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-45303?

Upgrade open-webui to 0.6.5 or later.

## Is CVE-2026-45303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45303 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45303 and fix it if it is affected.

What it is: CVE-2026-45303 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45303 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.5
- open-webui (PyPI): affected all versions; fixed in 0.6.5
- open-webui (PyPI): affected all versions; fixed in 0.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45303/ (Markdown: https://insights.sbomify.com/CVE-2026-45303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45303
- OSV: https://osv.dev/vulnerability/CVE-2026-45303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45303/
Summaries are generated and may contain mistakes; the official description above is the record.
