CVE-2026-45304 Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")
Attackers can cause memory exhaustion and denial of service by submitting malicious YAML input to the Symfony YAML parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45304?
CVE-2026-45304 is a high-severity denial of service vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Weakness: CWE-776
Which versions are affected by CVE-2026-45304?
16 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
10 more packages
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45304?
Upgrade symfony/symfony to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-45304 being exploited?
There is no known exploitation of CVE-2026-45304 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1784682954, CLSA-2026-1786399295, DEBIAN-CVE-2026-45304, GHSA-4qpc-3hr4-r2p4, MINI-88q9-mhr3-3256, MINI-mcw6-373c-mwph and 2 more.