CVE-2026-45305 Symfony: YAML Parser ReDoS via Catastrophic Backtracking in Parser::cleanup() Regex
Attackers can cause denial of service in Symfony applications by submitting crafted YAML input that triggers catastrophic backtracking in the parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45305?
CVE-2026-45305 is a high-severity denial of service vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser::cleanup() used regular expressions with overlapping quantifiers for YAML directive, comment, and document marker cleanup, allowing crafted input to make parsing hang for an arbitrarily long time. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Weakness: CWE-1333
Which versions are affected by CVE-2026-45305?
16 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
10 more packages
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | All versions | 5.4.52 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 6.0.0 | 6.4.40 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 7.0.0 | 7.4.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
symfony/yaml Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45305?
Upgrade symfony/symfony to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-45305 being exploited?
There is no known exploitation of CVE-2026-45305 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1784250519, DEBIAN-CVE-2026-45305, GHSA-9frc-8383-795m, MINI-4qhc-28vq-75m7, MINI-9vr6-rpww-62cq, MINI-q2cv-jw55-3j7v and 1 more.