# CVE-2026-45307: Speakr: Open redirect in is_safe_url via parser mismatch on next parameter

> An open redirect in Speakr allows attackers to redirect users to malicious sites via a parser mismatch in the next parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-5cpp-mqgh-4c38

## What is CVE-2026-45307?

CVE-2026-45307 is a medium-severity vulnerability in murtaza-nasir speakr, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Speakr is a personal, self-hosted web application designed for transcribing audio recordings. Prior to 0.8.20-alpha, the is_safe_url() helper used to validate post-login redirect targets applied urljoin(request.host_url, target) before parsing, while the controller passed the raw target to redirect(). A scheme-relative input such as ////evil.com resolved to a same-host URL during validation but was emitted verbatim in the Location header, where the browser interpreted it as a network-path-relative redirect to an attacker-controlled host. This vulnerability is fixed in 0.8.20-alpha.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-45307?


## How do I fix CVE-2026-45307?

No fix has been published for CVE-2026-45307 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45307 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45307 and fix it if it is affected.

What it is: CVE-2026-45307 is a medium-severity vulnerability in murtaza-nasir speakr, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45307 exists.

Affected product: murtaza-nasir speakr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45307/ (Markdown: https://insights.sbomify.com/CVE-2026-45307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45307
- OSV: https://osv.dev/vulnerability/CVE-2026-45307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45307/
Summaries are generated and may contain mistakes; the official description above is the record.
