# CVE-2026-45310: CodeWhale: SSRF via HTTP Redirect Bypass in fetch_url Tool

> Attackers can bypass SSRF protections in CodeWhale's fetch_url tool by using HTTP redirects to access internal network resources.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 30 May 2026
- **Also known as:** GHSA-96ff-gc8g-wpvg

## What is CVE-2026-45310?

CVE-2026-45310 is a high-severity server-side request forgery vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeWhale is a DeepSeek + MiMo coding agent in terminal. Prior to 0.8.22, the fetch_url tool validates the initial URL's resolved IP address against a restricted-IP blocklist (is_restricted_ip()) to prevent SSRF attacks against internal services (cloud metadata endpoints, localhost, private networks). However, the HTTP client (reqwest) is configured to automatically follow up to 5 redirects (reqwest::redirect::Policy::limited(5)) without re-validating the redirect target against the same SSRF protections. This vulnerability is fixed in 0.8.22.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-45310?

6 open source packages ship an affected version, including deepseek-tui and deepseek-tui-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepseek-tui` | crates.io | All versions | 0.8.22 |
| `deepseek-tui` | crates.io | All versions | 0.8.22 |
| `deepseek-tui` | npm | All versions | 0.8.22 |
| `deepseek-tui` | npm | All versions | 0.8.22 |
| `deepseek-tui-cli` | crates.io | All versions | 0.8.22 |
| `deepseek-tui-cli` | crates.io | All versions | 0.8.22 |

## How do I fix CVE-2026-45310?

Upgrade deepseek-tui to 0.8.22 or later.

## Is CVE-2026-45310 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45310 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45310 and fix it if it is affected.

What it is: CVE-2026-45310 is a high-severity server-side request forgery vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45310 exists.

Affected packages and fixed versions:
- deepseek-tui (crates.io): affected all versions; fixed in 0.8.22
- deepseek-tui (crates.io): affected all versions; fixed in 0.8.22
- deepseek-tui (npm): affected all versions; fixed in 0.8.22
- deepseek-tui (npm): affected all versions; fixed in 0.8.22
- deepseek-tui-cli (crates.io): affected all versions; fixed in 0.8.22
- deepseek-tui-cli (crates.io): affected all versions; fixed in 0.8.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45310/ (Markdown: https://insights.sbomify.com/CVE-2026-45310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45310
- OSV: https://osv.dev/vulnerability/CVE-2026-45310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45310/
Summaries are generated and may contain mistakes; the official description above is the record.
