CVE-2026-45311 CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval

Critical 9.6 Published Updated

Attackers can achieve remote code execution by tricking the CodeWhale agent into running malicious tests from a repository without user approval.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-45311?

CVE-2026-45311 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

CodeWhale is a DeepSeek + MiMo coding agent in terminal. From 0.3.0 to 0.8.23, the run_tests tool executes cargo test in the workspace with ApprovalRequirement::Auto, meaning it runs without any user approval prompt. cargo test compiles and executes arbitrary code: test binaries, build.rs build scripts, and proc macros. While auto-approving test execution is a deliberate design choice, it creates an inconsistency in the security boundary. However, in a malicious repository, test code can execute arbitrary shell commands, exfiltrate credentials, or establish persistence with zero approval. The attack is amplified by AGENTS.md (auto-loaded into the system prompt), which can instruct the model to run tests proactively at session start. This vulnerability is fixed in 0.8.23.

Weakness: CWE-94

Which versions are affected by CVE-2026-45311?

6 open source packages ship an affected version, including deepseek-tui and deepseek-tui-cli.

PackageAffectedFixed in
deepseek-tui crates.ioFrom 0.3.00.8.23
deepseek-tui crates.ioFrom 0.3.00.8.23
deepseek-tui npmFrom 0.3.00.8.23
deepseek-tui npmFrom 0.3.00.8.23
deepseek-tui-cli crates.ioFrom 0.3.00.8.23
deepseek-tui-cli crates.ioFrom 0.3.00.8.23

How do I fix CVE-2026-45311?

Upgrade deepseek-tui to 0.8.23 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-45311 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45311 exists.

Sources

Also known as GHSA-wx44-2q6h-j6p8.

Is CVE-2026-45311 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free