# CVE-2026-45311: CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval

> Attackers can achieve remote code execution by tricking the CodeWhale agent into running malicious tests from a repository without user approval.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-wx44-2q6h-j6p8

## What is CVE-2026-45311?

CVE-2026-45311 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeWhale is a DeepSeek + MiMo coding agent in terminal. From 0.3.0 to 0.8.23, the run_tests tool executes cargo test in the workspace with ApprovalRequirement::Auto, meaning it runs without any user approval prompt. cargo test compiles and executes arbitrary code: test binaries, build.rs build scripts, and proc macros. While auto-approving test execution is a deliberate design choice, it creates an inconsistency in the security boundary. However, in a malicious repository, test code can execute arbitrary shell commands, exfiltrate credentials, or establish persistence with zero approval. The attack is amplified by AGENTS.md (auto-loaded into the system prompt), which can instruct the model to run tests proactively at session start. This vulnerability is fixed in 0.8.23.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-45311?

6 open source packages ship an affected version, including deepseek-tui and deepseek-tui-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepseek-tui` | crates.io | From 0.3.0 | 0.8.23 |
| `deepseek-tui` | crates.io | From 0.3.0 | 0.8.23 |
| `deepseek-tui` | npm | From 0.3.0 | 0.8.23 |
| `deepseek-tui` | npm | From 0.3.0 | 0.8.23 |
| `deepseek-tui-cli` | crates.io | From 0.3.0 | 0.8.23 |
| `deepseek-tui-cli` | crates.io | From 0.3.0 | 0.8.23 |

## How do I fix CVE-2026-45311?

Upgrade deepseek-tui to 0.8.23 or later.

## Is CVE-2026-45311 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45311 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45311 and fix it if it is affected.

What it is: CVE-2026-45311 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45311 exists.

Affected packages and fixed versions:
- deepseek-tui (crates.io): affected from 0.3.0; fixed in 0.8.23
- deepseek-tui (crates.io): affected from 0.3.0; fixed in 0.8.23
- deepseek-tui (npm): affected from 0.3.0; fixed in 0.8.23
- deepseek-tui (npm): affected from 0.3.0; fixed in 0.8.23
- deepseek-tui-cli (crates.io): affected from 0.3.0; fixed in 0.8.23
- deepseek-tui-cli (crates.io): affected from 0.3.0; fixed in 0.8.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45311/ (Markdown: https://insights.sbomify.com/CVE-2026-45311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45311
- OSV: https://osv.dev/vulnerability/CVE-2026-45311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45311/
Summaries are generated and may contain mistakes; the official description above is the record.
