# CVE-2026-45313: Sandboxie-Plus: Sandboxie APC Injection Sandbox Escape

> A sandboxed process can execute arbitrary code in an unsandboxed host process with SYSTEM privileges due to insufficient validation of APC injection parameters.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-rmv3-fhg3-75xh

## What is CVE-2026-45313?

CVE-2026-45313 is a high-severity vulnerability in sandboxie-plus Sandboxie, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Sandboxie-Plus is an open source sandbox-based isolation software for Windows. Prior to 1.17.6, GuiServer::WndHookRegisterSlave in Sandboxie/core/svc/GuiServer.cpp stores attacker-supplied hthread and hproc fields from a GUI_WND_HOOK_REGISTER request without validating that the thread belongs to the sandboxed process or that the function pointer is in the caller address space, and GuiServer::WndHookNotifySlave then calls OpenThread(THREAD_SET_CONTEXT, FALSE, whk->hthread) and QueueUserAPC((PAPCFUNC)whk->hproc, hThread, (ULONG_PTR)req->threadid) as SYSTEM, allowing a sandboxed process to execute arbitrary code in an unsandboxed host process. This issue is fixed in version 1.17.6.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-45313?


## How do I fix CVE-2026-45313?

No fix has been published for CVE-2026-45313 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45313 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45313 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45313 and fix it if it is affected.

What it is: CVE-2026-45313 is a high-severity vulnerability in sandboxie-plus Sandboxie, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45313 exists.

Affected product: sandboxie-plus Sandboxie. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45313/ (Markdown: https://insights.sbomify.com/CVE-2026-45313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45313
- OSV: https://osv.dev/vulnerability/CVE-2026-45313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45313/
Summaries are generated and may contain mistakes; the official description above is the record.
