# CVE-2026-45314: Open WebUI: XSS via SVG in /api/v1/channels/webhooks/{webhook_id}/profile/image

> Attackers can execute arbitrary scripts in victim browsers by uploading malicious SVG profile images to Open WebUI channel webhooks.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-3856-3vxq-m6fc, PYSEC-2026-2694

## What is CVE-2026-45314?

CVE-2026-45314 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.3, the channel webhook create/update flow accepts arbitrary profile_image_url values, including data:image/svg+xml;base64,... payloads. The profile image endpoint then decodes and serves this SVG as image/svg+xml without sanitization, allowing attacker-controlled script handlers (for example onload) to execute when the profile-image URL is opened in the browser. This vulnerability is fixed in 0.9.3.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax)

## Which versions are affected by CVE-2026-45314?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-45314?

Upgrade open-webui to 0.9.3 or later.

## Is CVE-2026-45314 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45314 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45314 and fix it if it is affected.

What it is: CVE-2026-45314 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45314 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45314/ (Markdown: https://insights.sbomify.com/CVE-2026-45314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45314
- OSV: https://osv.dev/vulnerability/CVE-2026-45314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45314/
Summaries are generated and may contain mistakes; the official description above is the record.
