# CVE-2026-45315: Open WebUI: Stored XSS via attacker-controlled file extension in /api/v1/audio/transcriptions

> Attackers can execute arbitrary scripts in other users' browsers by uploading malicious files with spoofed extensions to the audio transcription endpoint.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-m8f9-9whg-f4xr, PYSEC-2026-2748

## What is CVE-2026-45315?

CVE-2026-45315 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.3, the audio transcription upload endpoint takes the file extension from the user-supplied filename and saves the file under CACHE_DIR/audio/transcriptions/.. The /cache/{path} route serves these files via FileResponse, which sets Content-Type from the on-disk extension and emits no Content-Disposition. A verified user with the default-on chat.stt permission can upload a polyglot WAV+HTML file named pwn.html and trick any other user into opening the resulting URL — the response comes back as text/html and any embedded <script> runs in the Open WebUI origin. This vulnerability is fixed in 0.9.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-646 (Reliance on File Name or Extension of Externally-Supplied File), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-45315?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-45315?

Upgrade open-webui to 0.9.3 or later.

## Is CVE-2026-45315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45315 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45315 and fix it if it is affected.

What it is: CVE-2026-45315 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45315 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45315/ (Markdown: https://insights.sbomify.com/CVE-2026-45315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45315
- OSV: https://osv.dev/vulnerability/CVE-2026-45315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45315/
Summaries are generated and may contain mistakes; the official description above is the record.
