# CVE-2026-45317: Open WebUI: Cross-Site Request Forgery (CSRF) via Image URL Manipulation

> Attackers can exploit CSRF in Open WebUI image uploads to perform actions on behalf of victims, potentially leading to cookie theft or denial of service.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-j6w6-986j-2m2m, PYSEC-2026-2738

## What is CVE-2026-45317?

CVE-2026-45317 is a medium-severity vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.3, an application-wide Cross-Site Request Forgery (CSRF) vulnerability was found Open-WebUl's image uploading functionality. An attacker can set an image URL to a malicious endpoint, allowing them to perform actions on behalf of a victim user. Any authenticated user can exploit this vulnerability, and any user who views the compromised image (e.g., a profile picture) will unknowingly send a GET request to the attacker-controlled URL. This can lead to cookie theft, denial of service (DoS), or other malicious actions. This vulnerability is fixed in 0.9.3.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-45317?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |
| `open-webui` | PyPI | All versions | 0.9.3 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-45317?

Upgrade open-webui to 0.9.3 or later.

## Is CVE-2026-45317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45317 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45317 and fix it if it is affected.

What it is: CVE-2026-45317 is a medium-severity vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45317 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3
- open-webui (PyPI): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45317/ (Markdown: https://insights.sbomify.com/CVE-2026-45317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45317
- OSV: https://osv.dev/vulnerability/CVE-2026-45317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45317/
Summaries are generated and may contain mistakes; the official description above is the record.
