CVE-2026-45330 Decidim: Verification admins can access supplied IDs from other organisations
Administrators in one tenant can view, approve, or reject identity verification requests from other tenants due to missing ownership checks.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45330?
CVE-2026-45330 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the identity-document verification admin controllers load pending Authorization records by raw identifier without confirming current_organization ownership, allowing an administrator from one tenant to view, approve, or reject another tenant’s ID-document request. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Which versions are affected by CVE-2026-45330?
6 open source packages ship an affected version, including decidim-verifications.
| Package | Affected | Fixed in |
|---|---|---|
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45330?
Upgrade decidim-verifications to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-45330 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45330 exists.
Sources
Also known as GHSA-86fh-w43w-338c.