# CVE-2026-45334: Kirby: Content locks disclose IDs and emails of inaccessible users from `users.access/list` permissions

> Low-privilege users can view email addresses and IDs of locked users, enabling account enumeration and phishing attacks.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-39vq-49qm-r2mc

## What is CVE-2026-45334?

CVE-2026-45334 is a medium-severity vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, the content-locking feature returned lock information without checking the requesting user's access permissions. Kirby's Panel includes a content-locking feature that records which user currently has a model open for editing. This lock prevents conflicting edits by multiple users and displays the locking user's identity in the Panel UI so other users know who to contact. Internally, the locking user's email address and identifier are included in every Panel view payload and in error responses returned when a user attempts to edit a model that is currently locked by another user. This allowed a low-privilege authenticated Panel user, whose role was configured with users.access: false or users.list: false, to learn the email address and identifier of any user who currently had a model open for editing in the Panel, including administrators and other higher-privilege users. Content locks are active for a configurable window (10 minutes by default). The email address can allow admin account enumeration, target phishing, and feed credential-stuffing attacks against the Kirby installation or other sites. The internal user ID can be cross-referenced with other endpoints once the requester has obtained a higher privilege through unrelated means. This issue has been fixed in versions 4.9.1 and 5.4.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-45334?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |

## How do I fix CVE-2026-45334?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.

## Is CVE-2026-45334 being exploited?

There is no known exploitation of CVE-2026-45334 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45334 and fix it if it is affected.

What it is: CVE-2026-45334 is a medium-severity vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45334 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45334/ (Markdown: https://insights.sbomify.com/CVE-2026-45334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45334
- OSV: https://osv.dev/vulnerability/CVE-2026-45334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45334/
Summaries are generated and may contain mistakes; the official description above is the record.
