# CVE-2026-45350: Open WebUI: Chat completion API allows tool restrictions to be bypassed

> Attackers can bypass tool restrictions in the chat completion API to invoke server tools with elevated privileges, potentially executing unauthorized actions.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-4pcg-253r-rf9w, PYSEC-2026-2700

## What is CVE-2026-45350?

CVE-2026-45350 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.8.6, there is a vulnerability in chat completion API, which allows attackers to bypass tool restrictions, potentially enabling unauthorized actions or access. In the chat_completion API, the parameters tool_ids and tool_servers are supplied by the user. These parameters are used to create a tools_dict by the middleware. This is then used by get_tool_by_id to retrieve the appropriate tool. However, there is no checks in that ensures the user that uses the API has permission to use the tool, meaning that a user can invoke any server tool by supplying the correct tool_id or tool_servers parameters via the chat completion API. Moreover, the authentication token stored in the server would be used when invoking the tool, so the tool will be invoked with the server privilege. This vulnerability is fixed in 0.8.6.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-45350?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.8.6 |
| `open-webui` | PyPI | All versions | 0.8.6 |
| `open-webui` | PyPI | All versions | 0.8.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-45350?

Upgrade open-webui to 0.8.6 or later.

## Is CVE-2026-45350 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45350 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45350 and fix it if it is affected.

What it is: CVE-2026-45350 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45350 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.8.6
- open-webui (PyPI): affected all versions; fixed in 0.8.6
- open-webui (PyPI): affected all versions; fixed in 0.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45350/ (Markdown: https://insights.sbomify.com/CVE-2026-45350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45350
- OSV: https://osv.dev/vulnerability/CVE-2026-45350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45350/
Summaries are generated and may contain mistakes; the official description above is the record.
