CVE-2026-45353 electerm: Local code through electerm's single-instance socket
Attackers can execute arbitrary code locally via electerm's single-instance socket mechanism, affecting users of the terminal client.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45353?
CVE-2026-45353 is a critical code injection vulnerability in electerm, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From 3.0.6 to 3.8.8, This vulnerability is fixed in 3.9.0.
Which versions are affected by CVE-2026-45353?
2 open source packages ship an affected version, including electerm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
electerm npm | From 3.0.6 | 3.9.0 |
electerm npm | From 3.0.6 | 3.9.0 |
Products include Electerm Project Electerm.
How do I fix CVE-2026-45353?
Upgrade electerm to 3.9.0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-45353 being exploited?
There is no known exploitation of CVE-2026-45353 in the wild and no public exploit code.
Other vulnerabilities in electerm
- CVE-2026-41500 electerm has Command Injection Vulnerability via runMac function
- CVE-2026-41501 electerm has Command Injection Vulnerability via runLinux function
- CVE-2020-23256 electerm allows unauthorized users to execute arbitrary commands
- CVE-2026-43941 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click
- CVE-2026-43944 electerm: dangerous code can be run through links or command line
Sources
Also known as GHSA-7p5m-v798-f8vv.