{"answers":{"affected":"2 open source packages ship an affected version, including electerm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-45353 in the wild and no public exploit code.","fix":"Upgrade electerm to 3.9.0 or later.","what":"CVE-2026-45353 is a critical code injection vulnerability in electerm, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45353 and fix it if it is affected.\n\nWhat it is: CVE-2026-45353 is a critical code injection vulnerability in electerm, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45353 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- electerm (npm): affected from 3.0.6; fixed in 3.9.0\n- electerm (npm): affected from 3.0.6; fixed in 3.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45353/ (Markdown: https://insights.sbomify.com/CVE-2026-45353/index.md)","id":"CVE-2026-45353","markdown":"https://insights.sbomify.com/CVE-2026-45353/index.md","name":"CVE-2026-45353","record":{"aliases":["GHSA-7p5m-v798-f8vv"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"electerm terminal client","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code locally via electerm's single-instance socket mechanism, affecting users of the terminal client.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"electerm","vendor":"electerm_project"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-940","name":"Improper Verification of Source of a Communication Channel"},{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From 3.0.6 to 3.8.8,  This vulnerability is fixed in 3.9.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"electerm: Local code through electerm's single-instance socket","id":"CVE-2026-45353","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"LiquidJS: Memory and render limit bypass via unbounded width padding in `date` filter (strftime)","id":"CVE-2026-45357"},"packages":[{"ecosystem":"npm","fixed":["3.9.0"],"introduced":["3.0.6"],"last_affected":[],"package":"electerm","purl":null,"source":"GHSA-7p5m-v798-f8vv"},{"ecosystem":"npm","fixed":["3.9.0"],"introduced":["3.0.6"],"last_affected":[],"package":"electerm","purl":"pkg:npm/electerm","source":"GHSA-7p5m-v798-f8vv"}],"prev":{"headline":"cpp-httplib DoS: Negative chunk-size in chunked Transfer-Encoding","id":"CVE-2026-45352"},"products":["electerm"],"published":"2026-05-28","related":[{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runMac function","id":"CVE-2026-41500","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runLinux function","id":"CVE-2026-41501","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm allows unauthorized users to execute arbitrary commands","id":"CVE-2020-23256","kev_date_added":null,"published":"2023-01-20"},{"cvss_score":9.6,"headline":"Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click","id":"CVE-2026-43941","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.4,"headline":"electerm: dangerous code can be run through links or command line","id":"CVE-2026-43944","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":8.4,"headline":"electerm: Path traversal in electerm runWidget leads to arbitrary code execution","id":"CVE-2026-43940","kev_date_added":null,"published":"2026-05-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["electerm"]},"summary":"Attackers can execute arbitrary code locally via electerm's single-instance socket mechanism, affecting users of the terminal client.","url":"https://insights.sbomify.com/CVE-2026-45353/"}