# CVE-2026-45353: electerm: Local code through electerm's single-instance socket

> Attackers can execute arbitrary code locally via electerm's single-instance socket mechanism, affecting users of the terminal client.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-7p5m-v798-f8vv

## What is CVE-2026-45353?

CVE-2026-45353 is a critical code injection vulnerability in electerm, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From 3.0.6 to 3.8.8,  This vulnerability is fixed in 3.9.0.

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel), CWE-94 (Improper Control of Generation of Code), CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-45353?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | From 3.0.6 | 3.9.0 |
| `electerm` | npm | From 3.0.6 | 3.9.0 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-45353?

Upgrade electerm to 3.9.0 or later.

## Is CVE-2026-45353 being exploited?

There is no known exploitation of CVE-2026-45353 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2026-41501](https://insights.sbomify.com/CVE-2026-41501/): electerm has Command Injection Vulnerability via runLinux function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-43944](https://insights.sbomify.com/CVE-2026-43944/): electerm: dangerous code can be run through links or command line (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45353 and fix it if it is affected.

What it is: CVE-2026-45353 is a critical code injection vulnerability in electerm, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45353 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected from 3.0.6; fixed in 3.9.0
- electerm (npm): affected from 3.0.6; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45353/ (Markdown: https://insights.sbomify.com/CVE-2026-45353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45353
- OSV: https://osv.dev/vulnerability/CVE-2026-45353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45353/
Summaries are generated and may contain mistakes; the official description above is the record.
