# CVE-2026-45361: Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default

> Attackers can intercept or modify SSH sessions between Airflow workers and Compute Engine VMs due to disabled host key verification.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** ECHO-c5a7-8dd9-27d6, GHSA-g9v5-gjwf-9rwx, MINI-3p9c-v3qm-9m3x, MINI-r6c7-64h5-m7mf, PYSEC-2026-166

## What is CVE-2026-45361?

CVE-2026-45361 is a high-severity vulnerability in Apache Airflow Google provider, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default, exposing SSH traffic between an Airflow worker and a Compute Engine VM to in-path network attackers who can intercept or modify the session. Users are advised to upgrade to `apache-airflow-providers-google` 22.0.0 or later.

Weakness: CWE-322 (Key Exchange without Entity Authentication)

## Which versions are affected by CVE-2026-45361?

3 open source packages ship an affected version, including apache-airflow-providers-google. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-google` | PyPI | All versions | 22.0.0 |
| `apache-airflow-providers-google` | PyPI | All versions | 22.0.0 |
| `apache-airflow-providers-google` | PyPI | All versions | 22.0.0 |

Products: Apache Apache-Airflow-Providers-Google.

## How do I fix CVE-2026-45361?

Upgrade apache-airflow-providers-google to 22.0.0 or later.

## Is CVE-2026-45361 being exploited?

There is no known exploitation of CVE-2026-45361 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Google provider

- [CVE-2023-25691](https://insights.sbomify.com/CVE-2023-25691/): Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution (critical 9.8)
- [CVE-2026-49297](https://insights.sbomify.com/CVE-2026-49297/): Apache Airflow Google provider allows path traversal through GCS object names (high 8.1)
- [CVE-2023-25692](https://insights.sbomify.com/CVE-2023-25692/): Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service (high 7.5)
- [CVE-2026-68868](https://insights.sbomify.com/CVE-2026-68868/): Missing authorization in Apache Airflow Google provider (medium 6.5)
- [CVE-2026-81914](https://insights.sbomify.com/CVE-2026-81914/): Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45361 and fix it if it is affected.

What it is: CVE-2026-45361 is a high-severity vulnerability in Apache Airflow Google provider, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45361 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.0.0
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.0.0
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45361/ (Markdown: https://insights.sbomify.com/CVE-2026-45361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45361
- OSV: https://osv.dev/vulnerability/CVE-2026-45361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45361/
Summaries are generated and may contain mistakes; the official description above is the record.
