# CVE-2026-45364: Better Auth: Rate limiter keys IPv6 addresses individually and is bypassable via prefix rotation

> Attackers can bypass rate limiting in Better Auth by rotating IPv6 addresses or varying their textual encoding, enabling brute-force attacks on authentication endpoints.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-p6v2-xcpg-h6xw

## What is CVE-2026-45364?

CVE-2026-45364 is a high-severity vulnerability in better-auth, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth is an authentication and authorization library for TypeScript. Prior to 1.4.17 and 1.5.0-beta.9, Better Auth's HTTP rate limiter keyed each request by the exact textual IP address it received in x-forwarded-for (or the configured IP-bearing header). IPv6 clients controlling a typical /64 allocation could rotate through 2^64 distinct source addresses without exhausting the per-address counter, defeating rate limiting on /sign-in/email, /sign-up/email, /forget-password, and every other path the limiter protects. The same bug allowed a single client to vary the textual encoding of one IPv6 address (uppercase, compression, IPv4-mapped, hex-encoded IPv4-in-IPv6) and produce multiple distinct keys. This vulnerability is fixed in 1.4.17 and 1.5.0-beta.9.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-45364?

4 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.4.17 |
| `better-auth` | npm | All versions | 1.4.17 |
| `better-auth` | npm | From 1.5.0-beta.1 | 1.5.0-beta.9 |
| `better-auth` | npm | From 1.5.0-beta.1 | 1.5.0-beta.9 |

## How do I fix CVE-2026-45364?

Upgrade better-auth to a fixed version for your release line: 1.4.17 or 1.5.0-beta.9.

## Is CVE-2026-45364 being exploited?

There is no known exploitation of CVE-2026-45364 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45364 and fix it if it is affected.

What it is: CVE-2026-45364 is a high-severity vulnerability in better-auth, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45364 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.4.17
- better-auth (npm): affected all versions; fixed in 1.4.17
- better-auth (npm): affected from 1.5.0-beta.1; fixed in 1.5.0-beta.9
- better-auth (npm): affected from 1.5.0-beta.1; fixed in 1.5.0-beta.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45364/ (Markdown: https://insights.sbomify.com/CVE-2026-45364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45364
- OSV: https://osv.dev/vulnerability/CVE-2026-45364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45364/
Summaries are generated and may contain mistakes; the official description above is the record.
