# CVE-2026-45367: HAPI FHIR: ReDoS via FHIRPath matches()/replaceMatches() in FHIR Validator HTTP Endpoint

> Attackers can cause denial of service in HAPI FHIR applications by submitting malicious regular expressions to FHIRPath validation endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-3653-68v6-rq57, ROOT-APP-MAVEN-CVE-2026-45367

## What is CVE-2026-45367?

CVE-2026-45367 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.7, the FHIRPathEngine implementation passes user-controlled regular expressions from matches(), matchesFull(), and replaceMatches() to Java regex operations without effective timeouts, allowing catastrophic backtracking and denial of service. This issue is fixed in version 6.9.7.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-45367?

16 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.dstu2, ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may and ca.uhn.hapi.fhir:org.hl7.fhir.dstu3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.7 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.7 |

## How do I fix CVE-2026-45367?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 to 6.9.7 or later.

## Is CVE-2026-45367 being exploited?

There is no known exploitation of CVE-2026-45367 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45367 and fix it if it is affected.

What it is: CVE-2026-45367 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45367 in the wild and no public exploit code.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.9.7
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45367/ (Markdown: https://insights.sbomify.com/CVE-2026-45367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45367
- OSV: https://osv.dev/vulnerability/CVE-2026-45367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45367/
Summaries are generated and may contain mistakes; the official description above is the record.
