{"answers":{"affected":"4 open source packages ship an affected version, including getkirby/cms.","exploited":"There is no known exploitation of CVE-2026-45368 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.","what":"CVE-2026-45368 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45368 and fix it if it is affected.\n\nWhat it is: CVE-2026-45368 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-45368 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45368/ (Markdown: https://insights.sbomify.com/CVE-2026-45368/index.md)","id":"CVE-2026-45368","markdown":"https://insights.sbomify.com/CVE-2026-45368/index.md","name":"CVE-2026-45368","record":{"aliases":["GHSA-qvjf-922g-pj44"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in the site frontend via malicious URLs in KirbyTags and image blocks, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, the underlying URL methods for the KirbyTags and image blocks components did not filter out malicious URL values that resolve to script execution. The vulnerability affects four first-party Kirby renderers that produce `\u003ca href=\"…\"\u003e` output from editor-supplied field values: the (`link: …)` KirbyTag, the `link`: parameter of the `(image: …)` KirbyTag when it does not resolve to a known file or `self`, the `link` field of the built-in image block, and the HTML importer for the `blocks` field (which accepted the same malicious input as the image block `link` field). While simple `avascript:` URLs were already deactivated by treating them as a relative path and prepending a single slash to the URL, the use of URLs of the format `javascript://x%0A…` bypasses this protection. The `vbscript:`, `data:`, `livescript:`, `mocha:` and `jar:` schemes are affected by the same underlying gap. This issue has been fixed in versions 4.9.1 and 5.4.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby: Cross-site scripting (XSS) from links in KirbyTags and image blocks in the site frontend","id":"CVE-2026-45368","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"python-utcp: Command Injection via Unsanitized Argument Substitution in CLI Communication Protocol","id":"CVE-2026-45369"},"packages":[{"ecosystem":"Packagist","fixed":["4.9.1"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-qvjf-922g-pj44"},{"ecosystem":"Packagist","fixed":["4.9.1"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-qvjf-922g-pj44"},{"ecosystem":"Packagist","fixed":["5.4.1"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-qvjf-922g-pj44"},{"ecosystem":"Packagist","fixed":["5.4.1"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-qvjf-922g-pj44"}],"prev":{"headline":"HAPI FHIR: ReDoS via FHIRPath matches()/replaceMatches() in FHIR Validator HTTP Endpoint","id":"CVE-2026-45367"},"products":["kirby"],"published":"2026-07-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-18","vendors":["getkirby"]},"summary":"Attackers can execute arbitrary scripts in the site frontend via malicious URLs in KirbyTags and image blocks, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-45368/"}