{"answers":{"affected":"2 open source packages ship an affected version, including deepseek-tui.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45374 exists.","fix":"Upgrade deepseek-tui to 0.8.26 or later.","what":"CVE-2026-45374 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45374 and fix it if it is affected.\n\nWhat it is: CVE-2026-45374 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45374 exists.\n\nAffected packages and fixed versions:\n- deepseek-tui (crates.io): affected all versions; fixed in 0.8.26\n- deepseek-tui (crates.io): affected all versions; fixed in 0.8.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45374/ (Markdown: https://insights.sbomify.com/CVE-2026-45374/index.md)","id":"CVE-2026-45374","markdown":"https://insights.sbomify.com/CVE-2026-45374/index.md","name":"CVE-2026-45374","record":{"aliases":["GHSA-72w5-pf8h-xfp4"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AI coding agent","requires_auth":"none","summary":"Attackers can achieve remote code execution by exploiting insecure default settings in the task_create tool that grant unapproved shell access to sub-agents.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"CodeWhale is a DeepSeek + MiMo coding agent in terminal. Prior to 0.8.26, the task_create tool spawns durable sub-agents that inherit two insecure defaults, allow_shell defaults to true (config.rs:1499: self.allow_shell.unwrap_or(true)) and auto_approve defaults to true (task_manager.rs:297: auto_approve: Some(true)). When a user approves a task_create call (which requires ApprovalRequirement::Required), they approve what appears to be a benign work prompt. However, the spawned sub-agent silently receives unrestricted, unapproved shell access. This vulnerability is fixed in 0.8.26.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files","id":"CVE-2026-45374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"SiYuan Bazaar marketplace renders unescaped package `name` and `version` metadata, allowing stored XSS and Electron code execution","id":"CVE-2026-45375"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.26"],"introduced":["0"],"last_affected":[],"package":"deepseek-tui","purl":null,"source":"GHSA-72w5-pf8h-xfp4"},{"ecosystem":"crates.io","fixed":["0.8.26"],"introduced":["0"],"last_affected":[],"package":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","source":"GHSA-72w5-pf8h-xfp4"}],"prev":{"headline":"CodeWhale: SSRF‌ IPV6 bypass","id":"CVE-2026-45373"},"products":["CodeWhale"],"published":"2026-05-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-30","vendors":["Hmbown"]},"summary":"Attackers can achieve remote code execution by exploiting insecure default settings in the task_create tool that grant unapproved shell access to sub-agents.","url":"https://insights.sbomify.com/CVE-2026-45374/"}