# CVE-2026-45374: CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files

> Attackers can achieve remote code execution by exploiting insecure default settings in the task_create tool that grant unapproved shell access to sub-agents.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 30 May 2026
- **Also known as:** GHSA-72w5-pf8h-xfp4

## What is CVE-2026-45374?

CVE-2026-45374 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeWhale is a DeepSeek + MiMo coding agent in terminal. Prior to 0.8.26, the task_create tool spawns durable sub-agents that inherit two insecure defaults, allow_shell defaults to true (config.rs:1499: self.allow_shell.unwrap_or(true)) and auto_approve defaults to true (task_manager.rs:297: auto_approve: Some(true)). When a user approves a task_create call (which requires ApprovalRequirement::Required), they approve what appears to be a benign work prompt. However, the spawned sub-agent silently receives unrestricted, unapproved shell access. This vulnerability is fixed in 0.8.26.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-45374?

2 open source packages ship an affected version, including deepseek-tui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepseek-tui` | crates.io | All versions | 0.8.26 |
| `deepseek-tui` | crates.io | All versions | 0.8.26 |

## How do I fix CVE-2026-45374?

Upgrade deepseek-tui to 0.8.26 or later.

## Is CVE-2026-45374 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45374 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45374 and fix it if it is affected.

What it is: CVE-2026-45374 is a critical code injection vulnerability in Hmbown CodeWhale, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45374 exists.

Affected packages and fixed versions:
- deepseek-tui (crates.io): affected all versions; fixed in 0.8.26
- deepseek-tui (crates.io): affected all versions; fixed in 0.8.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45374/ (Markdown: https://insights.sbomify.com/CVE-2026-45374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45374
- OSV: https://osv.dev/vulnerability/CVE-2026-45374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45374/
Summaries are generated and may contain mistakes; the official description above is the record.
