CVE-2026-45376 Decidim: Admin user search allows SQL injection through similarity-based sorting
An authenticated admin can execute blind SQL queries via search parameters to infer sensitive data through timing differences.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45376?
CVE-2026-45376 is a medium-severity SQL injection vulnerability in decidim, published on 31 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the GET /admin/organization/users search interpolates params[:term] into raw Arel.sql ORDER BY similarity expressions before sanitization, allowing an authenticated organization administrator to execute blind PostgreSQL expressions and infer data through timing differences. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Weakness: CWE-89
Which versions are affected by CVE-2026-45376?
6 open source packages ship an affected version, including decidim-admin.
| Package | Affected | Fixed in |
|---|---|---|
decidim-admin RubyGems | All versions | 0.30.9 |
decidim-admin RubyGems | All versions | 0.30.9 |
decidim-admin RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-admin RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-admin RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-admin RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45376?
Upgrade decidim-admin to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-45376 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45376 exists.
Sources
Also known as GHSA-jvqq-cvh4-xm37.