{"answers":{"affected":"6 open source packages ship an affected version, including decidim-admin.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45376 exists.","fix":"Upgrade decidim-admin to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.","what":"CVE-2026-45376 is a medium-severity SQL injection vulnerability in decidim, published on 31 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45376 and fix it if it is affected.\n\nWhat it is: CVE-2026-45376 is a medium-severity SQL injection vulnerability in decidim, published on 31 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45376 exists.\n\nAffected packages and fixed versions:\n- decidim-admin (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-admin (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-admin (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-admin (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-admin (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n- decidim-admin (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45376/ (Markdown: https://insights.sbomify.com/CVE-2026-45376/index.md)","id":"CVE-2026-45376","markdown":"https://insights.sbomify.com/CVE-2026-45376/index.md","name":"CVE-2026-45376","record":{"aliases":["GHSA-jvqq-cvh4-xm37"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"high_privilege","summary":"An authenticated admin can execute blind SQL queries via search parameters to infer sensitive data through timing differences.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the GET /admin/organization/users search interpolates params[:term] into raw Arel.sql ORDER BY similarity expressions before sanitization, allowing an authenticated organization administrator to execute blind PostgreSQL expressions and infer data through timing differences. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Decidim: Admin user search allows SQL injection through similarity-based sorting","id":"CVE-2026-45376","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":6,"n_references":7,"next":{"headline":"Decidim: Private exports can be downloaded through reusable links","id":"CVE-2026-45377"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-admin","purl":null,"source":"GHSA-jvqq-cvh4-xm37"},{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-admin","purl":"pkg:gem/decidim-admin","source":"GHSA-jvqq-cvh4-xm37"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-admin","purl":null,"source":"GHSA-jvqq-cvh4-xm37"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-admin","purl":"pkg:gem/decidim-admin","source":"GHSA-jvqq-cvh4-xm37"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-admin","purl":null,"source":"GHSA-jvqq-cvh4-xm37"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-admin","purl":"pkg:gem/decidim-admin","source":"GHSA-jvqq-cvh4-xm37"}],"prev":{"headline":"SiYuan Bazaar marketplace renders unescaped package `name` and `version` metadata, allowing stored XSS and Electron code execution","id":"CVE-2026-45375"},"products":["decidim"],"published":"2026-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-03","vendors":["decidim"]},"summary":"An authenticated admin can execute blind SQL queries via search parameters to infer sensitive data through timing differences.","url":"https://insights.sbomify.com/CVE-2026-45376/"}