CVE-2026-45378 Decidim: Verification documents can be downloaded through reusable links
Attackers can download sensitive identity verification documents via reusable signed URLs without authentication, exposing private user data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45378?
CVE-2026-45378 is a high-severity vulnerability in decidim, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the identity-document verification admin UI embeds verification_attachment blobs through reusable signed Active Storage disk URLs, allowing anyone who obtains a URL to download the scanned document without an authenticated Decidim session until the signature expires. Verification-document images are rendered with variant_url(...), which produces signed /rails/active_storage/disk/... links instead of routing the file through an authorization-checking controller. Because Decidim configures Active Storage service URLs to remain valid for seven days, the URL itself becomes the credential for that period. The affected files are verification_attachment blobs on Decidim::Authorization, and the admin review pages embed those signed URLs directly into the HTML for pending and confirmation views. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Weakness: CWE-200
Which versions are affected by CVE-2026-45378?
6 open source packages ship an affected version, including decidim-verifications.
| Package | Affected | Fixed in |
|---|---|---|
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45378?
Upgrade decidim-verifications to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.
Is CVE-2026-45378 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45378 exists.
Sources
Also known as GHSA-3mvf-82qp-8qh5.