# CVE-2026-4538: PyTorch pt2 Loading deserialization

> A local attacker can exploit a deserialization flaw in PyTorch's pt2 loading handler to execute arbitrary code.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2026
- **Updated:** 23 Mar 2026
- **Also known as:** BIT-pytorch-2026-4538, DEBIAN-CVE-2026-4538, ECHO-1421-5c4b-5062, GHSA-33x2-ppm4-v46v, PYSEC-2026-139, UBUNTU-CVE-2026-4538

## What is CVE-2026-4538?

CVE-2026-4538 is a medium-severity unsafe deserialization vulnerability in PyTorch, published on 22 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was identified in PyTorch 2.10.0. The affected element is an unknown function of the component pt2 Loading Handler. The manipulation leads to deserialization. The attack can only be performed from a local environment. The exploit is publicly available and might be used. The project was informed of the problem early through a pull request but has not reacted yet.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-4538?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | From 2.10.0 | 2.11.0 |
| `torch` | PyPI | All versions to 2.10.0 | None |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2026-4538?

Upgrade pytorch to 2.11.0 or later.

## Is CVE-2026-4538 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4538 exists.

## Other vulnerabilities in PyTorch

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4538 and fix it if it is affected.

What it is: CVE-2026-4538 is a medium-severity unsafe deserialization vulnerability in PyTorch, published on 22 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4538 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected from 2.10.0; fixed in 2.11.0
- torch (PyPI): affected all versions up to 2.10.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4538/ (Markdown: https://insights.sbomify.com/CVE-2026-4538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4538
- OSV: https://osv.dev/vulnerability/CVE-2026-4538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4538/
Summaries are generated and may contain mistakes; the official description above is the record.
