{"answers":{"affected":"3 open source packages ship an affected version, including pygments and Pygments.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4539 exists.","fix":"Upgrade pygments to 2.20.0 or later.","what":"CVE-2026-4539 is a medium-severity denial of service vulnerability in pygments, published on 22 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-4539 and fix it if it is affected.\n\nWhat it is: CVE-2026-4539 is a medium-severity denial of service vulnerability in pygments, published on 22 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4539 exists.\n\nAffected packages and fixed versions:\n- pygments (PyPI): affected all versions; fixed in 2.20.0\n- pygments (PyPI): affected all versions; fixed in 2.20.0\n- Pygments (PyPI): affected all versions; fixed in 2.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4539/ (Markdown: https://insights.sbomify.com/CVE-2026-4539/index.md)","id":"CVE-2026-4539","markdown":"https://insights.sbomify.com/CVE-2026-4539/index.md","name":"CVE-2026-4539","record":{"aliases":["CLEANSTART-2026-AU68896","CLEANSTART-2026-ER46931","DEBIAN-CVE-2026-4539","ECHO-c58f-806e-ab85","GHSA-5239-wwwm-4pmq","MGASA-2026-0090","MINI-5f94-4jcw-69gq","MINI-6453-6vgh-8cwc","MINI-64f3-4hj4-vg3f","MINI-742p-f4ph-jjqp","MINI-88q7-5x4f-qc3x","MINI-9rj4-cqfq-gxmc","MINI-cj4f-rmjj-8vc8","MINI-f6hh-pj8x-9mr5","MINI-g3h7-79q9-2wjp","MINI-g3vh-jww8-8q52","MINI-gfc7-c49r-m8gv","MINI-mp8w-jgq5-5x86","MINI-q4w3-6v5j-f2vm","MINI-v9w3-xr9r-2vxv","MINI-xrm6-r5gm-rjxx","MINI-xvmm-2f47-vqwh","MINI-xvmp-q428-4jcf","OESA-2026-1873","PYSEC-2026-2987","SUSE-SU-2026:1666-1","SUSE-SU-2026:1667-1","SUSE-SU-2026:22058-1","SUSE-SU-2026:22093-1","UBUNTU-CVE-2026-4539","openSUSE-SU-2026:10476-1","openSUSE-SU-2026:20931-1"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python syntax highlighting library","requires_auth":"low_privilege","summary":"A local attacker can cause a denial of service in the Pygments library via inefficient regular expressions in the AdlLexer component.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.","ecosystems":["PyPI","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Micro 6.2","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pygments archetype.py AdlLexer redos","id":"CVE-2026-4539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":8,"n_references":5,"next":{"headline":"projectworlds Online Notes Sharing System Parameters login.php sql injection","id":"CVE-2026-4540"},"packages":[{"ecosystem":"PyPI","fixed":["2.20.0"],"introduced":["0"],"last_affected":[],"package":"Pygments","purl":null,"source":"GHSA-5239-wwwm-4pmq"},{"ecosystem":"PyPI","fixed":["2.20.0"],"introduced":["0"],"last_affected":[],"package":"pygments","purl":"pkg:pypi/pygments","source":"GHSA-5239-wwwm-4pmq"},{"ecosystem":"PyPI","fixed":["2.20.0"],"introduced":["0"],"last_affected":[],"package":"pygments","purl":"pkg:pypi/pygments","source":"PYSEC-2026-2987"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["2.19.1-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Pygments","purl":"pkg:rpm/suse/python-Pygments\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22093-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["2.19.1-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Pygments","purl":"pkg:rpm/suse/python-Pygments\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22093-1"},{"ecosystem":"SUSE:Linux Micro 6.2","fixed":["2.19.1-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Pygments","purl":"pkg:rpm/suse/python-Pygments\u0026distro=SUSE%20Linux%20Micro%206.2","source":"SUSE-SU-2026:22058-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.19.1-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Pygments","purl":"pkg:rpm/opensuse/python-Pygments\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20931-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.20.0-2.1"],"introduced":["0"],"last_affected":[],"package":"python-Pygments","purl":"pkg:rpm/opensuse/python-Pygments\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10476-1"}],"prev":{"headline":"PyTorch pt2 Loading deserialization","id":"CVE-2026-4538"},"products":["pygments"],"published":"2026-03-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-23","vendors":["n/a"]},"summary":"A local attacker can cause a denial of service in the Pygments library via inefficient regular expressions in the AdlLexer component.","url":"https://insights.sbomify.com/CVE-2026-4539/"}