CVE-2026-45414 Decidim: JWT-backed authentication can be replayed across organizations

High 8.5 Published Updated

Attackers can replay JWTs across tenants to access unauthorized participant data and proposal endpoints in Decidim.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45414?

CVE-2026-45414 is a high-severity authentication bypass vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Decidim is a participatory democracy framework. Prior to 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, JWT-backed API authentication is not bound to the organization selected by the current host, allowing a JWT issued for one tenant to be replayed against another tenant’s API to read participantDetails data and reach the proposal.answer mutation path. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.

Weakness: CWE-863, CWE-639

Which versions are affected by CVE-2026-45414?

4 open source packages ship an affected version, including decidim.

PackageAffectedFixed in
decidim RubyGemsAll versions0.31.5
decidim RubyGemsAll versions0.31.5
decidim RubyGemsFrom 0.32.0.rc10.32.0
decidim RubyGemsFrom 0.32.0.rc10.32.0

How do I fix CVE-2026-45414?

Upgrade decidim to a fixed version for your release line: 0.31.5 or 0.32.0.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-45414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45414 exists.

Sources

Also known as GHSA-r3v7-5x4c-c69q.

Is CVE-2026-45414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free