{"answers":{"affected":"4 open source packages ship an affected version, including decidim.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45414 exists.","fix":"Upgrade decidim to a fixed version for your release line: 0.31.5 or 0.32.0.","what":"CVE-2026-45414 is a high-severity authentication bypass vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45414 and fix it if it is affected.\n\nWhat it is: CVE-2026-45414 is a high-severity authentication bypass vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45414 exists.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected all versions; fixed in 0.31.5\n- decidim (RubyGems): affected all versions; fixed in 0.31.5\n- decidim (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n- decidim (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45414/ (Markdown: https://insights.sbomify.com/CVE-2026-45414/index.md)","id":"CVE-2026-45414","markdown":"https://insights.sbomify.com/CVE-2026-45414/index.md","name":"CVE-2026-45414","record":{"aliases":["GHSA-r3v7-5x4c-c69q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim platform","requires_auth":"low_privilege","summary":"Attackers can replay JWTs across tenants to access unauthorized participant data and proposal endpoints in Decidim.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Decidim is a participatory democracy framework. Prior to 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, JWT-backed API authentication is not bound to the organization selected by the current host, allowing a JWT issued for one tenant to be replayed against another tenant’s API to read participantDetails data and reach the proposal.answer mutation path. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Decidim: JWT-backed authentication can be replayed across organizations","id":"CVE-2026-45414","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":4,"n_references":5,"next":{"headline":"Decidim: CSV census record endpoints improper authorization","id":"CVE-2026-45415"},"packages":[{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-r3v7-5x4c-c69q"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-r3v7-5x4c-c69q"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-r3v7-5x4c-c69q"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-r3v7-5x4c-c69q"}],"prev":{"headline":"MaxKB: Unsalted MD5 Password Hashing","id":"CVE-2026-45413"},"products":["decidim"],"published":"2026-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-07","vendors":["decidim"]},"summary":"Attackers can replay JWTs across tenants to access unauthorized participant data and proposal endpoints in Decidim.","url":"https://insights.sbomify.com/CVE-2026-45414/"}